Compile errors


I'm running Solaris 8 and using Sun C/C++ 5.0. I just finished compiling the
latest GTK/Pango/Atk/Glib. I have a question, which I'll get to shortly.

For each of the packages, there is a --enable-gtk-doc option for enabling
the generation of documentation. I have been unsuccessful to date in
compiling the necessary programs to get this option to work correctly.
Therefore, I run configure without this option, since the default is to NOT
build this documentation. However, I still get make errors when make falls
into the doc directory. An example of this error message is:

make: Warning: Don't know how to make target 'all-local'
Current working directory /export/develop/tools/atk-1.0.2/docs

Yes, I can run make with the "-k" option, which I have to do to get past
this. However, I guess I'm confused that I've not requested the docs to be
built and yet make fails while trying to build them...

Is this:
1) A problem with the configure options
2) A problem with my environment
3) The way it works

I would like to resolve this so I'd appreciate suggestions, other than "use
make -k".



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]