Re: pango-rc1-1.0.0 fails configure under hp-ux 11.00

jacob berkman <jacob ximian com> writes:

> > ...
> > ls: /opt/pango-1.0.0/lib/pango/modules/*.so: No such file or directory
> > No dynamic modules were installed; all modules were linked statically.
> > ...
> what is in /opt/pango-1.0.0/lib/pango/modules ?
> pango/modules/ has this:
>     if PLATFORM_WIN32
>     SOSUFFIX=dll
>     else
>     SOSUFFIX=so
>     endif
> which is totally bogus :)  does libtool export its library suffix
> finding functions, or is hp-ux the only other platform not using .so?

I think this was one of those things where:

 - I wrote some quick rule a long time ago to work on my system
 - Havoc fixed it up when *.so didn't match anything because of 
   static linking.
 - Tor or Hans fixed it for Win32

And nobody noticed that it was completely unportable, and in fact the
*.so glob wasn't necessary at all because pango-querymodules does the
right thing when run without any arguments.

(I fixed pango-querymodules last week to be flexible for extensions,
but didn't notice this makefile rule.)

The rc2 tarball fixes the problem by running pango-querymodules
without arguments.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]