Re: g_error function names

Dov Grobgeld <dov imagic weizmann ac il> writes:

> I started using the GError mechanism and I encountered the function
> names g_set_error(), g_propagate_error(), and g_clear_error(). Shouldn't
> these be g_error_set(), g_error_propagate(), etc? Should I put this
> as a bug in Bugzilla?

I think there's a lot of sense in this naming convention. GError
functions that start with g_error_ work on the GError itself while the
functions ending in _error take the memory location of the error as an
argument. I've found this very convenient, please don't change it.

Salut, Sven

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]