solution for Making glib 2.00, 2.02

I just wanted to report the following (little) thing I ran into when doing
'make' for glib2.00 and 2.02:

'make' broke off w following error:

Making all in libcharset
make[3]: Entering directory `/usr/temp/glib-2.0.0/glib/libcharset'
make[3]: Nothing to be done for `all'.
make[3]: Leaving directory `/usr/temp/glib-2.0.0/glib/libcharset'
make[3]: Entering directory `/usr/temp/glib-2.0.0/glib'
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..
-O2 -Wall -D_REENTRANT -c giounix.c
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -DG_LOG_DOMAIN=\"GLib\"
giounix.c  -fPIC -DPIC -o giounix.o
giounix.c: In function `g_io_unix_read':
giounix.c:181: `SSIZE_MAX' undeclared (first use in this function)
giounix.c:181: (Each undeclared identifier is reported only once
giounix.c:181: for each function it appears in.)
make[3]: *** [giounix.lo] Error 1
make[3]: Leaving directory `/usr/temp/glib-2.0.0/glib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/temp/glib-2.0.0/glib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/temp/glib-2.0.0'
make: *** [all-recursive-am] Error 2

I solved it by adding

"#include <bits/posix1_lim.h>"

to the file giounix.c
after that, it compiled just fine, maybe it should be included there
always? I'm just a poor joe the user, but luckily I found this out and was
able to use glib...


Matthijs van Henten

my configuration:
slacware 8.0
gcc 2.95.3 20010315
kernel 2.4.12

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]