[no subject]



So, perhaps the right thing to do is that we add:
 
 gtk_label_set/get_label ()
 gtk_label_set/get_use_markup ()
 gtk_label_set/get_use_underline ()

And all of:

 gtk_label_set_markup
 gtk_label_set_markup_with_mnemonic
 gtk_label_set_text_with_mnemonic
 gtk_label_set_pattern

Are just convenience functions that do some combination of the above.

Attributes is a little stickier because it doesn't fit into
the property model - when ::use_markup is set it will be
overridden sometimes, but not always, depending on the order.

Actually, I think this is conceptually broken. If use_markup
is set, gtk_label_attributes and the ::attributes property
should be ignored. There are multiple ways to go about this:

 1) ->attrs is only affected by set/get_attributes, ::attributes.
    The effective attributes are 

     pango_layout_get_attributes (gtk_label_get_layout (label));

    Caching layout->effective_attrs also possible but doesn't 
    affect the API. This is cleanest, but maybe a little
    less efficient. (probably doesn't matter.)

 2) When use_markup is set, gtk_label_set_attributes() is
    ignored and gtk_label_get_attributes() returns the 
    attributes derived from the markup.
 
> XXXX gtk_notebook_get_page (-> gtk_notebook_get_current_page)

Hmm, probably should rename gtk_notebook_set_page() to 
gtk_notebook_set_current_page(), and leave a deprecated macro
for compat.

> XXXX gtk_radio_button_get_group (-> gtk_radio_button_group)
> XXXX gtk_radio_menu_item_get_group (-> gtk_radio_menu_item_group)

There's an open bug to fix these to gtk_radio_button_get_group(),
(#55516)

> [gtk_ruler_get_metric]

Conceptually makes sense. You can scan over the metric array
and do pointer comparisons to find out the value.

> XXXX gtk_settings_get_property_value [private]
> XXXX gtk_settings_get_string_property [private]
> XXXX gtk_settings_get_long_property [private]
> XXXX gtk_settings_get_double_property [private]

Not actually completely private, but don't need getters - getter is
g_object_get().

> [gtk_style_get_background]

gtk_style_set_background() modifies a window based on the style,
doesn't 

> DONE gtk_text_layout_get_default_style
> DONE gtk_text_layout_get_screen_width
> DONE gtk_text_layout_get_contexts
> [gtk_text_layout_get_preedit_string]

Not needed. GtkTextLayout is only basically public 

> [gtk_text_view_get_border_window_size]

Should be added.

> DONE gtk_tree_item_get_subtree
> XXXX gtk_tree_view_column_get_tree_view [private]

> [gtk_tree_selection_get_select_function]
> [gtk_tree_sortable_sort_column_id_get_func]

Suggested name change to gtk_tree_sortable_set_sort_func(). 
(#56266). 

Not sure if a getter for either of these makes sense - the fact that
it is a func/data/destroy triplet makes people accessing it externally
dubious.

> XXXX gtk_tree_store_get_n_columns [private]
> XXXX gtk_tree_store_get_column_type [private]

I'm not sure what is meant here by [private].

> [gtk_tree_store_get_value]
> [gtk_tree_store_get_valist]
> [gtk_tree_view_get_headers_clickable]
> [gtk_tree_view_get_column_drag_function]
> [gtk_tree_view_get_rows_drag_source]
> [gtk_tree_view_get_rows_drag_dest]
> [gtk_tree_view_column_get_attributes]
> [gtk_tree_view_column_get_cell_data_func]
> [gtk_tree_view_column_cell_get_cell_data]

> [gtk_widget_get_scroll_adjustments]

Can't be implemented.

> [gtk_decorated_window_get_title]

gtk_decorated_window_set_title() is a private interface - public
interface is gtk_window_set/get_title.

> [gtk_window_get_geometry_hints]

I think this might be in a big outstanding GtkWindow size patch.
Probably best to wait on this one.

Regards,
                                        Owen




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]