Re: "GString" vs. "gstring". (David Wheeler) writes:

> The type names of "gstring" and "GString" are, uhm, rather similar :-).
> This seems confusing; it certainly makes them harder to talk about.
> I'd like to see one of these type names changed so that their names
> differ by more than case.  Aliases could be created for the original
> names of types & functions, so no code would need to break.
> The "old" name could be deprecated & removed several years hence.
> Here are a few ideas; probably someone will have a better one:
> * "gstring"->"gstr" or "g_str".  This would be consistent with the
>   names of the functions dealing with them.
> * "GString" -> "GVString" (Variable-length string).

GString can't be changed and shouldn't be changed. It's in
thousands of programs.

gstring was added very recently, serves no useful purpose, 
and I'd like to see it just removed.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]