Re: glib-patch, where do I send it?



Derek Simkowiak wrote:
> 
> > * g_array_copy() - I think it speaks for itself
> > * g_ptr_array_copy()
> > * g_ptr_array_copy_deep() - Deep copying!
> > * g_byte_array_copy()
> > * g_list_copy_deep()
> > * g_slist_copy_deep()
> 
>         Are the g_ptr_* and g_byte_array_copy functions for use with a
> Glib's Array? Because if they are, they should probably be named
The g_ptr_* are for use with the GPtrArray type. Similarly the
g_byte_array_*
are for the GByteArray type.

> g_array_ptr_copy()
> g_array_ptr_deep_copy()
> g_array_byte_copy()
> 
>         ...in order to follow the current naming convention.
therefore I'd say my names still stick with the conventions. :)
I still use the prefixes/names as glib already has. Thus g_array_copy()
means
copying a GArray.

>         Also, I assume the g_array_copy() function is a deep copy...?
Yes it's a deep copy. It is a 'real' array which stores values rather
than
pointers. copying values is deep by default.

// Jorgen



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]