Re: name the text widget

> My best idea so far is to call the buffer object ("model")
> GtkTextBuffer and the widget part (the view/controller thing)
> GtkTextView. Better suggestions?

	I have been (internally) using the name GtkEtext (as in Extended
Text widget) for my up-and-coming widget.  It would be nice if you didn't
use that name :).

	I'd recommend having a name showing that the widget is not just a
plaintext widget; something like GtkStyledText, GtkRichText, GtkCText (as
in Colored Text), etc.  The widget uses alot of RAM to provide different
tags (and eventually images), and in the future we may want a very
low-resource "GtkText*" widget replacement that displays only a single
font, with no colors/images, as an option for a light-weight text widget.

	Also, I would recommend that you *not* call it GtkText[anything]
until it has been chosen as the official new Gtk+ 1.4 text widget.  There
will hopefully be several contenders to choose from as the new official
Gtk+ text widget (there are already GtkExText, GtkSCText, my GtkEtext, and
hopefully there will be more) and if the name GtkText[*] is already taken
by your widget it will be a headache if we want to name the
eventually-chosen widget to GtkText-something.

	(Just my $.02)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]