[gnomemm] libbonobomm compile problems

Hey there,
    To start out with, I have the latest orbitcpp and libbonobomm from CVS and I'm using
libbonobo revision gnome-2-4.  When I go to compile libbonobomm, it goes into a loop in
bonobo/generated (not sure why...).  Before giving you commands and outputs, I must tell
you that I use jhbuild and my prefix for ALL of my gnome stuff is /opt/gnome2. 
Everything works fine except for this.  Ok, after stopping this strange loop, I tried
some of the commands it was running, and on this command:

/opt/gnome2/bin/orbit-idl-2 -lcpp -D__Bonobo_COMPILATION  -D__Bonobo_Unknown_COMPILATION
-I//opt/gnome2/share/idl/bonobo-2.0 -I//opt/gnome2/share/idl/bonobo-activation-2.0

I get this output:

orbit-idl-2 2.8.2 compiling
  mode, show preprocessor errors, passes: stubs skels common headers skel_impl imodule
/opt/gnome2/share/idl/bonobo-2.0/Bonobo_Moniker.idl:23: not a type identifier:

I took a look at /opt/gnome2/share/idl/bonobo-2.0/Bonobo_Moniker.idl, and here's a chunk
of the idl in question (starting at line 14):

#include <Bonobo_Activation_types.idl>
#include "Bonobo_Unknown.idl"

module Bonobo {

	typedef long ResolveFlag;

	struct ResolveOptions {
		ResolveFlag  flags;
		long         timeout; /* in ms */

If I run the above command without the -lcpp option, it compiles fine.  I'm guessing this
is something to do with c++'s strict typecasting, but I'm not sure.  For some reason,
when  this command and others bail out, libbonobomm deletes the Makefile from the
bonobo/generated dir.  This may be a completely separate issue, but I thought I would
bring it up since it's a pain to have to run configure each time I test if I've fixed
this.  And no, I haven't found a fix for this.  If you need any more info, feel free to
email me back.  Thanks in advance!

-Bryan Forbes

Do you Yahoo!?
Exclusive Video Premiere - Britney Spears

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]