[GnomeMeeting-devel-list] Libebook issues


since (at least) yesterday I have the following warnings in console when running gnomemeeting-snapshot :
GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

I noticed that :
- if I use dominance's package, I have those warnings, and libebook warnings :
libebook-WARNING **: Can't find installed BookFactories
- if I recompile dominance's package locally, I only have the g_propagate_error warnings.

This morning, I tried to run (my compiled) gnomemeeting-snapshot in gdb with the --g-fatal-warnings option, to see where the abort would occur, and got the following trace :
#0  0xb6612a27 in raise () from /lib/tls/libc.so.6
#1  0xb661435b in abort () from /lib/tls/libc.so.6
#2  0xb7627dbd in g_logv () from /usr/lib/libglib-2.0.so.0
#3  0xb7627dee in g_log () from /usr/lib/libglib-2.0.so.0
#4  0xb7627f18 in g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
#5  0xb760f74c in g_propagate_error () from /usr/lib/libglib-2.0.so.0
#6  0xb786ab51 in e_book_new_system_addressbook ()
   from /usr/lib/libebook-1.2.so.5
#7  0xb786ac56 in e_book_new_default_addressbook ()
   from /usr/lib/libebook-1.2.so.5
#8  0x080c5a33 in gnomemeeting_get_local_addressbooks ()
#9  0x08079bd4 in gm_addressbook_window_new ()
#10 0x08094d08 in GnomeMeeting::BuildGUI ()
#11 0x080a11c9 in main ()

With :
ldd /usr/bin/gnomemeeting-snapshot | grep ebook
        libebook-1.2.so.5 => /usr/lib/libebook-1.2.so.5 (0xb7851000)

Then I tried the same with dominance's package :
#0  0xb680da27 in raise () from /lib/tls/libc.so.6
#1  0xb680f35b in abort () from /lib/tls/libc.so.6
#2  0xb7823dbd in g_logv () from /usr/lib/libglib-2.0.so.0
#3  0xb7823dee in g_log () from /usr/lib/libglib-2.0.so.0
#4  0xb7a2e226 in e_book_new () from /usr/lib/libebook-1.2.so.3
#5  0xb7a2e6d2 in e_book_new_from_uri () from /usr/lib/libebook-1.2.so.3
#6  0xb7a2e866 in e_book_new_system_addressbook ()
   from /usr/lib/libebook-1.2.so.3
#7  0xb7a2e9c6 in e_book_new_default_addressbook ()
   from /usr/lib/libebook-1.2.so.3
#8  0x080c61d3 in gnomemeeting_get_local_addressbooks ()
#9  0x08079d14 in gm_addressbook_window_new ()
#10 0x08094f48 in GnomeMeeting::BuildGUI ()
#11 0x080a140e in main ()

With :
ldd /usr/bin/gnomemeeting-snapshot | grep ebook
        libebook-1.2.so.3 => /usr/lib/libebook-1.2.so.3 (0xb79c9000)

Notice that with my rebuilt package, the abort is on a "g_propagate_error: assertion `src != NULL' failed" warning, while with dominance's, the abort is on a "Can't find installed BookFactories" warning.

I'll check if gnomemeeting's code does proper error checking ; if so then the issue is certainly in libebook...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]