Re: gnome-vfs and smb:// URI's - am I doing something wrong?

On Thu, 27 Mar 2003, Paul Duran wrote:

> basically the code is:
> int main( int argc, char *argv[] )
> {
>      GnomeVFSResult result;
>      GList *list;
>      gnome_vfs_init(0;
>      result = gnome_vfs_directory_list_load( &list, argv[1], 0 );
>      printf("RESULT: %s\n", gnome_vfs_result_to_string(result));
> }
> Whenever I call this with smb:// URI's (with correct login information etc)
> I get: 
> RESULT: Access denied

Strange. The code looks fine. What version of gnome-vfs-extras is this? 
There was some problems with an earlier one where you had to read the smb: 
and smb://hostname/ dirs before logging in worked.

> As you can see, the client (ie: my app) is apparently trying to
> connect to a share at: /tmp. There is no share of that name
> in my samba config and that is why I am getting Access Denied.
> The question is, why is it trying to connect to a /tmp share.

No idea..
> This happens regardless of the hostname or the path (share name) that
> I use as I have tried on a couple of machines.
> any help would be appreciated!

If you want to debug it, try rebuilding gnome-vfs-extras with DEBUG_SMB 
enabled in smb-method.c.

 Alexander Larsson                                            Red Hat, Inc 
                   alexl redhat com    alla lysator liu se 
He's a leather-clad hunchbacked barbarian on the hunt for the last specimen of 
a great and near-mythical creature. She's an enchanted blonde advertising 
executive on the trail of a serial killer. They fight crime! 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]