Re: Problems compiling gnome-pilot-0.1.65 with pilot-link-0.11.1

Thanks a lot Brett!  That seemed to fix the problem and it compiled nicely!



From: "Brett A. Thomas" <quark baz com>
Reply-To: gnome-pilot-list gnome org

On Tue, 2002-07-30 at 21:26, Mike Musson wrote:
> As I understand it, those symbols come from the which has been > installed in my /usr/local/lib directory by pilot-link. I made sure that > path was in the file and I ran ldconfig but still get the same > problem. I also made sure there was no pilot-link rpm packages installed.
> I'm out of ideas.
> Any help is much appreciated!!
> Cheers,
> Mike


The problem is that configure is a generated file, and the supplied
patch only patched its source.  The latest pilot-link split into two
libraries, and configure is not generating makefiles that know about the
new library.

You have two choices:  You can either rebuild configure - check the
README and perhaps here:

I discovered that to be annoying, so, you do what I did and edit
configure and change it so that every place it says "-lpisync" it says
"-lpisync -lpisock".  Note you'll have to add quotes at least one place
were there is an assignment like:

  FOO = -lpisync

That will now need to be:

  FOO = "-lpisync -lpisock"

You can tell if this worked or not by whether configure properly finds
your pilot-link.  Oh, and, also, I don't know how your system is
configured, but I didn't have a lot of luck with having pilot-link live
somewhere other than the gnome system stuff (i.e., gnome in /usr and
pilot-link in /usr/local).  But that might just be because I'm
thick-headed and was rushing through, simply trying to get it to work
instead of understanding _how_ it works.  That's probably why I couldn't
figure out how to rebuild configure, either, although in my defense I
found that FAQ after I'd already edited configure by hand.

Also, should the gnome-pilot Gods be listening, I'm still having my
problem where it won't work with a Treo - gnome-pilot basically does
nothing.  This is after a format-reinstall from a hardware problem.
Pilot-link works fine on its own.  I haven't had time to debug it.


Chat with friends online, try MSN Messenger:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]