Re: What goes wrong with glib?

"Mike Newman", "Carsten Weinberg", "Kent Eschenberg",
"Telsa Gwynne" and "Daniel" have participated in this
reply (see below)...

I understood and performed your instructions,
"Daniel", but was not helpful!
Can you offer me a step by step instruction?
Can't I convert the glib tar package to rpm?
I am tired!

Thank you for your notice,

Bahram Alinezhad,
Tehran, Iran.

Your Response To Me (3):

Just thought I'd reply.. hope this helps:
Make sure you install glib's .pc file in a location
that will be seen by pkg-config.
/usr/lib/pkgconfig is where the .pc files should go by
default.. if you are installing glib in a location
other than /lib then you may need to adjust your
PKG_CONFIG_PATH when compiling programs that are
dependent on glib.

Sorry.. I meant .. if you install glib in a prefix
other than /usr then you may need to adjust your

eg.. If you use

./configure --prefix=/opt

for glib then when you compile pango you will need to

export PGK_CONFIG_PATH=/opt/lib/pkgconfig
./configure --prefix=/opt

Make sure you install all the gnome packages into the
same prefix..
Hope this helps..


My Previous Message (3):

No, I didn't mean "glibc", I meant "glib" when I said:
"is required by about 100 other packages".
Also, I am not installing a beta version of gnome; I
want to install gnome 2.6.
Nevertheless, I removed the old glib rpm (with
--nodeps option), and installed "glib-2.4.2.tar.bz2"
again, but, still this error appears when trying to
install "pango-1.4.0.tar.bz2":

Glib 2.4.0 or better is required.

Thank you for your notice,

Bahram Alinezhad,
Tehran, Iran.

Your Response To Me (2):

Ah. Never confuse glib with glibc. glib (no 'c') is
used by Gnome programs, mostly. If you remove it,
Gnome programs may not work, but the system as a whole

glibc is used by just about everything on the system.
Never try to remove it unless you know exactly what
you're doing: things can break badly.

So what you have in your results is a mixture of
glib-1.x (probably there for compatibility with old
Gnome programs), glib2 (this is the glib used for
Gnome 2), and glibc.

You have a glib2, version 2.2.1, already. I am curious
why you need to compile a newer one. If you are trying
to install something else which relies upon it, then I
would try installing the matching -devel rpm as Mike
suggested: it will be glib2-devel-2.2.1-1.rpm.

Or were you trying to install a Gnome beta? I have
done this, but I haven't done it from tarballs. I tend
to use jhbuild, because that does all the nasty ldconf
(and so on) for me.

If you are installing a beta and want to retain your
working rpms, one trick I have found is to do this.

Make a directory called
/opt/something-not-already-used: /opt/gnome2/ is a
common one. Use chown to assign ownership of the
directory to you: chown user.user /opt/gnome2/ (where
user is your account name).

Then do ./configure --prefix=/opt for everything. (*)
And you can do everything as your normal user. I hate
being root when building things like this, because I
do not want to scribble all over working binaries.
This way, everything ends up in /opt (which I don't
normally use), and because I am a normal user, I can't
accidentally scribble over other parts of the system.
Some people use ~/gnome2 or ~/bin instead of
/opt/gnome2. Same reasoning.


My Previous Message (2):

> Thank you for your help: "Mike Newman" & "Carsten

But, glib is required by about 100 other packages in
the system; Should I completely uninstall the current
version of gnome and many other applications?

> Thank you for your help: "Kent Eschenberg",

This is the output of "rpm -qa|fgrep glib":

Bahram Alinezhad,
Tehran, Iran.

Your Response To Me (1):

I've seen this happen where an RPM of glib was
previously installed, but not glib-devel. When a later
glib is compiled and installed, remnants of the old
RPM installation along side a shiny new glib-2.0
pkgconfig file seem to confuse things.

I'd suggest removing the RPM of glib and reinstalling
the source of 2.4.2.


May be there are two glib's. one new and an old
release, lower than 2.4.0. pkg-config finds the old


Check that the installation of glib worked with rpm
-qa|fgrep glib

My Previous Message (1):

I install the package "glib-2.4.2.tar.bz2" according
to instructions and installation becomes complete
without any errors; Then, I want to install
"pango-1.4.0.tar.bz2" and it returns the error that
"glib 2.4.0 or later is required". I ran "ldconfig"
but had no effect!

I am using RedHat 9.0.

Thank you for your notice,

Bahram Alinezhad,
Tehran, Iran.

Do you Yahoo!?
Win 1 of 4,000 free domain names from Yahoo! Enter now.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]