How to compile nautilus2

Hi all,

over the weekend I tried to compile Gnome2 from tarballs. I downloaded
all the tarballs from a mirror ( and compiled according to
the dependency diagram. By doing this, I skipped a few packages (like
the xxx-mm ones). I experienced a few difficulties with the docbook
thingy, but in general everything went well except for nautilius.

I untarred the nautilus tarball, went into that directory and did a
'./configure --prefix=/opt/gnome2' and the compilation started.
Generally, the linking/creation of some libraries took a long time.  I
waited for more than one hour for the compiling/linking of
'test-nautilus-mime-actions-set.c' to finish what not happened. I
stopped then the compilation, deleted everything (the whole
nautilus-2.0.0 directory), untarrerd again and did a './configure
--prefix=/opt/gnome2 --disable-libtool-lock'. Then, the compilation got
stuck at the creation of nautilus. I stopped it after about 30 min. In
both cases, xosview showed 100%

After that, I decided to install the SuSE-rpms (nautilus and
nautilus-gtkhtml). Basically it works now, but using anti-aliased fonts
freezes the desktop (mouse can be moved but has no effect, keyboard not

I run a 1GHZ Athlon with a 448 MB memory, a 2.4.10 Kernel out of a

Any ideas what causes the long time for linking?

Best regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]