Local networking bug(s)

   For those who didn't already -- and/or don't want to -- read the 
preceding message, below, here's the condensed version:
   I configured my FBSD 4.4 box for networking on Feb. 1 and it 
worked fine for about 1 1/2 weeks.  Then, it suddenly started 
freezing -- totally unresponsive to keyboard, mouse, and remote 
logins -- at any sort of simple network request.  If I tried to 
telnet to or ping another server, it would lock up tight.  If I tried 
to ping it or log into it from another server, it would lock up tight.
  I can think of nothing that I did to my network configuration to 
make this happen.
   Late last night, bleary-eyed and about ready to call it quits 
while Googling just one more time for an answer, I found an old 
thread that looked promising.  (I was too tired to remember to 
bookmark it and now I can't find the magic combination of search 
words to find it, again! :-< )  Anyway, the gist of it was that one 
message in the thread came from a user who had run Gnome (as I am) on 
top of FBSD and had problems with his box freezing like mine.  Btw, I 
am also using the Sawfish wm.
   Unfortunately, I was too tired to think through a test scenario 
that might yield some useful results.  I was, however, awake and 
weary of the frustration of not being able to network for no apparent 
reason.  So, I renamed my rc.local file (which I use to start wdm and 
nothing else, by the way) and reboted my box.  My networking 
immediately came back to life.
   Here's the punchline: now, with my rc.local back in place, wdm and 
Gnome are running and I can rlogin back and forth, ping endlessly and 
have a veritable ethernet party and nothing seems to faze this box.
   Before last night (for a couple of days), I did many reboots 
(because I _had_ to) when I couldn't ping this machine.  With each 
boot, nothing changed as long as rc.local was in place, wdm started 
after booting, and I logged into a Gnome/Sawfish session.  Yet as 
soon as I took wdm, Gnome, and Sawfish out of the picture -- the 
networking came back.  This morning, I added them back in, one at a 
time, logged my process list as well as the contents of my /etc 
directory with each step in the hope of finding the offending process 
-- but now everything is back online and the networking is fine...  
Go figure.
   Well, if it happened before, it may happen again.  If it does, 
I'll try to take on piece out of play at a time to see if I can find 
the offender that way.  Otherwise, if anyone knows what the problem 
is and/or knows what the preventive fix is, I'd love to hear from 
you.  I will post this to the gnome-list as well as the 
freebsd-questions list in the hope of finding an answer and will also 
cross-post the answer, should one be posted to just one of these 

On Tuesday 12 February 2002 01:50 pm, Bob Giesen wrote:
>    First ff, I'd like to apologize if this message hits the list a
> second time, but I didn't receive the first one, so I'm resending
> it. Sorry, too, for the length, but I figured more info would be
> better than less.  Here's the original message:
>    I have two FBSD boxes connected via an ethenet hub that were
> talking just fine, last week (when I last rlogin'd from this
> machine to that one).  Last night, while online (via modem/ISP), I
> tried to rlogin again from this box (FBSD v4.4) to that one (v3.2),
> this box froze -- locked up so tight I had to do a hard reset.
>    When it rebooted, I ping'd myself (using both "localhost" and
> the hostname) successfully.  I then tried to:
> - ping the other machine
> - rlogin to this machine from the other one
> - ping this machine from the other one
> All of those actions caused this machine to lock up -- immediatedly
> and requiring a hard reset.  Ctrl-Alt-Delete would not work,
> Ctrl-Alt-Backspace would not dump the window manager, Ctrl-Alt-Fn
> would not bring up any of the vt's, the mouse pointer would not
> move, and no key combination I could think of had any visible
> effect, whatsoever.
>    Since, when I ping'd this machine, I could see the hub light
> flash with each packet send (and the light for this machine was
> glowing steadily, per normal operation), I suspected the physical
> networking might be okay, but I booted it to Win98 just to confirm.
>  With w98 running, this machine talks with that one, just fine.
>    So, something seems to be wrong with my FBSD configuration or
> software.  I have not purposely done anything to change my
> networking configuration since it last worked.  I have installed
> some new ports via ftp, which leads me to wonder if one of those
> might have misbehaved and put me in a pickle.
>    At this very moment, I am using FBSD while connected to the Net.
> I can ftp to other machines on the Net, but any attempt to talk to
> my other, local, machine would surely make this machine lock up. My
> hosts, hosts.allow, and inetd.conf files are unchanged since Jan.31
> and I had a working network more recently than that. I am not using
> this as a gateway to the net for the other machine. The other
> machine is currently booted to FBSD and I'm logged into it, too --
> yet I don't see it in a netstat -r listing on this machine. 
> (Shouldn't I?)  Below, I'll paste a list of my distfiles (some of
> which were brought in by dependencies), what netstat -r showed
> before I used ppp to connect to the Net, my ifconfig -a output, my
> dmesg output (which shows the evidence, at the end, of my having
> done a hard reset)
>   Any help would be very much appreciated.
> Thanks,
> Bob

"Your body makes saturated fats, and your body makes 
cholesterol-about 2000 mg per day. In general, cholesterol that the 
average American absorbs from food amounts to about 100 mg per day. 
So, in theory, even reducing animal foods to zero will result in only 
a 5% decrease in the total amount of cholesterol available to the 
blood and tissues. In practice, such a diet is likely to deprive the 
body of the substrates it needs to manufacture enough of this vital 
substance..." -- Mary G. Enig, Ph.D. and Sally Fallon in "The Oiling 
of America," originally published in Nexus Magazine in two parts, 
Nov/Dec 1998 and Feb/Mar 1999

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]