gnome-libs compilation problems

Hi all

I'm having problems compiling gnome-libs-1.2.3

At first it stopped when i ran ./configure with the message
checking for dbopen... no
checking for dbopen in -ldb1... no
checking for dbopen in -ldb... no
configure: error: Your db library is missing db 1.85 compatibility mode

After some searching in the mailinglists I found something about doing
export LDFLAGS="-L/usr/BerkeleyDB/lib/"
before configure, which worked.

However, I still have problems while running make. This is what i get:

gnome-dump.o: In function `main':
/usr/src/gnome/gnome-libs-1.2.3/libgnome/gnome-dump.c:75: undefined
reference to `__db185_open'
collect2: ld returned 1 exit status
make[2]: *** [gnome-dump-metadata] Error 1
make[2]: Leaving directory `/usr/src/gnome/gnome-libs-1.2.3/libgnome'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gnome/gnome-libs-1.2.3'
make: *** [all-recursive-am] Error 2

Any ideas?

Best regards

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]