Re: Problems with panel displaying icons

A line in the .spec file for gdk-pixbuf needs to be fixed (strangely enough,
this same error was in 0.7.0 and never got fixed, or somehow got broken again).
The line in the spec file looks something like


It's near the end of the spec file.  Anyways, you need to add a * to the end, so
it looks like


So, to make the fix, do something like

tar -zxf gdk-pixbuf-0.8.0.tar.gz
cd gdk-pixbuf-0.8.0
vim gdk-pixbuf.spec
[Make Changes]
cd ..
tar -zcf gdk-pixbuf-0.8.0.tar.gz gdk-pixbuf-0.8.0
rm -rf gdk-pixbuf-0.8.0
rpm -ta gdk-pixbuf-0.8.0.tar.gz

Someone had already posted a patch, but it's just as complicated if not worse to
apply a patch, so you might as well go ahead and use this.

Or, if you ask really, nice, I might send you my copy, but by the time you
downloaded it you really could do the above fix yourself... ^,^

Sean Middleditch

Telsa Gwynne wrote:

> I've gone through Gnotices, where kind people have posted things to
> try if specfiles are broken, but I haven't seen anything about gdk-pixbuf.
> How broken? Has some kind person already worked out the way to unbreak it?
> rpm -ta is my idea of technical as it is. Fixing specfiles sounds
> complicated.
> Not that I've actually managed to collect all the bits for 1.2 yet,
> but for when I do.. :)
> Telsa

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]