XF864.0+Gnome+"root" xterm+my ignorance=??

 I've recently downloaded and installed the XFree86 4.0 binary distribution
for Linux (glibc 2.1, I use a Mandrake 7 system); I managed to configure it
without any trouble with XF86Config (and Vim... ;), but!

 It came with a startup script that started twm, of course (I refer to
/etc/X11/xinit/xinitrc), and I tried to start Gnome just substituting the
"gnome-session" command to the "twm" one, and now I have something like

--------------------(: start :)--------------------
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $


# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap

if [ -f $userresources ]; then
    xrdb -merge $userresources

if [ -f $usermodmap ]; then
    xmodmap $usermodmap

# start some nice programs
exec xterm -geometry 1x1+2000+2000 -name root
--------------------): end :(--------------------

    ...that works, but... gnome starts with an xterm window called 'root' on
the screen;if I try to close it, the X server exit, and if I delete the
'exec xterm...' line, it doesn't even start. I tried to specify that
2000+2000 stuff you see to make it appear out of the screen, but it doesn't
seem to work, and what's worst of all, it doesn't appear ONE window, but
many... while I'm writing, I have 3 of these 'root' xterm, but they could be
also 10-12... I can kill them all but the last, so I guess they aren't

 Any suggestion? When I installed the distribution (with XFree 3.3.6), that
xterm wasn't there, so i guess there's a way to create it without
displaying, or to close it automatically... but since I'm not an expert of
scripts at all, I'd like to know how...

 Thanx in advance,
  Mano :)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]