Re: Error compiling Evolution-0.4.1

On Tue, Aug 29, 2000 at 09:09:05AM -0400, Louis Garcia wrote:
> ... problem when I run ./configure to compile Evolution. ...
> Error:
> checking for libunicode...  configure: error: libunicode not found.

  I've had that problem since evolution-0.0 since I keep libunicode
in /opt.

> I've installed libunicode versions .4 & .7.  I get the same error
> message. The libunicode libraries are installed in /usr/local/lib.

  I'm using libunicode-0.4 for what it is worth.

> I've tried running ./configure --x-libraries=/usr/local/lib.  This gives
> me the same error.
> Any assistance is greatly appreciated.

  The basic problem seems to be that Evolution's composer stomps on
CPPFLAGS, which doesn't let you tell it where your extra libraries are
like just about every other GNOME program.

  This is the patch I'm using, although you'll have to adjust it for
your own library location.

--- ./composer/	Wed May  3 21:07:30 2000
+++ ./composer/	Wed May 31 16:20:19 2000
@@ -19,6 +19,7 @@
 CPPFLAGS =					\
+	-I/opt/libunicode/include		\
 libcomposer_la_SOURCES = 			\

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]