Re: GMC/MC problems SOLVED :-) NOT =O(

>From: Gleef <>

>The GMC problem was due to a remnant from, I believe, an older GMC 
>version.  Some program put a link from "~/directory/Home directory" to
>"~". GMC was choking on this link quite ungracefully.  I removed the link,
>and it works fine now.  However, GMC really should have handled it without
>a segfault, I would call this a bug.

GMC adds this itself.  If you remove the entire ~/desktop directory, not just 
the link, running gmc recreates it again, and then cores again ;O)  As you say, 
removing just the link solves it.

I then had it SEGV in turn on a series of other files, seemingly all of which 
had non-alpha characters in them (eg .!dtmarkbo, .@desktop, .Bugtraqrc, etc) in  

0  0x6f3fc in re_match_2_internal (bufp=0xffbee810, string1=0x0, size1=0, 
    string2=0x182210 ".Bugtraqrc", size2=10, pos=0, regs=0x0, stop=10)
    at regex.c:3679

Which is:

   /* Initialize subexpression text positions to -1 to mark ones that no
      start_memory/stop_memory has been seen for. Also initialize the
      register information struct.  */
   for (mcnt = 1; mcnt < num_regs; mcnt++)
>      regstart[mcnt] = regend[mcnt] 
         = old_regstart[mcnt] = old_regend[mcnt] = REG_UNSET_VALUE;
And if this works for some files, and not others, I'm somewhat at a loss to why 

I worked my way through removing each of these files in turn for a while until I 
got bored of doing it.  It didn't spit on all of my ~/.??* files - just some of 
them.  I didn't get far enough to see if it SEGVs on files not starting with a 
".".  Most confusing.

Hope this is useful to someone,

-------My opinion - Not sane, intelligent or necessarily useful-------
o o                             
/v\ark R. Bowyer.  mailto:Mark.Bowyer@UK.Sun.COM
`-'                                             I'm the dots in

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]