Without trying to be overly critical, especially since I'm just a user
and don't envision being able to contribute much (not much of a programmer :)
to the project.
  I had problems upgrading from 99.0 to 99.1 due to the difference in 
versions of glib/gtk+ required (1.1.7 from the gnome mirror was okay for
99.0 but didn't cut it for 99.1) and I also got a couple of private emails
from people with the same problem asking how I fixed it, in the end it was
simple enough to upgrade to glib/gtk+ 1.1.11 which solved the problem. I've
also noticed Rebecca has been having problems and made a good point I think.
  Since 'autoconf' (and family) is being used, I think it would save some
people a few headaches and also cut down on some of the simple questions
on the list if 'configure' was kept a bit more updated with the actual
requirements (ie. I've noticed some of the tarballs just look for glib/gtk+
>= 1.1.0 or 1.1.4). It'd make things a bit more straight forward for people
if it'd just bomb out and notify the user that a required lib is out of date
or some other requirement isn't met. Sure would save having to stop, go get
the new lib, etc. and then recompile everything that depends on it and then
continue on from where to had to stop.
  I know its a bit more work to keep all the requirements, etc. in sync
with configure (especially at the pace the developement is going) but in
the long run I think it'd save some head aches all the way around :-)
Actually even just an updated README with all the current requirements would
serve the same purpose and be a little easier to maintain, that way a user
could make sure they had everything before even starting to build at all.

Life is just gambling. In the end, you always lose...

Mike Hall <>, (MH993)   -
System Administrator (*nix, Perl, CGI hacker, certified OS/2 Specialist)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]