a question concerning gnome-libs

Hello Gnome and Linux users from across the World ! ;-)

Sorry to interrupt your mailing list with a ignorant question like
this, but i'm having a long time (2 days, yes that is long in computer
age) problem compiling the gnome libs package. I just cant seem to get
past this one point ..

(cd .libs && ln -s ../libgtkxmhtml.la libgtkxmhtml.la)
/bin/sh ../libtool --mode=link gcc -g -O2  -o htmltest  test.o
../gtk-xmhtml/libgtkxmhtml.la -lXpm -ljpeg -lpng -lz -lz -lSM -lICE
-L/gnome/lib -L/usr/X11R6/lib -lgtk-1.1 -lgdk-1.1 -lglib-1.1 -lXext
-lX11 -lm  -lm
gcc -g -O2 -o .libs/htmltest test.o -Wl,--rpath -Wl,/gnome/lib
../gtk-xmhtml/.libs/libgtkxmhtml.so -lXpm -ljpeg -lpng -lz -lz -lSM
-lICE -L/gnome/lib -L/usr/X11R6/lib -lgtk-1.1 -lgdk-1.1 -lglib-1.1
-lXext -lX11 -lm -lm -lXpm -ljpeg -lpng -lz -lz -lSM -lICE
-L/gnome/lib -L/usr/X11R6/lib -lgtk-1.1 -lgdk-1.1 -lglib-1.1 -lXext
-lX11 -lm -lm
../gtk-xmhtml/.libs/libgtkxmhtml.so: undefined reference to `uncompress'
../gtk-xmhtml/.libs/libgtkxmhtml.so: undefined reference to `compress'
collect2: ld returned 1 exit status
make[2]: *** [htmltest] Error 1
make[2]: Leaving directory `/cuttingedge/gnome-libs/gtk-xmhtml'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cuttingedge/gnome-libs'
make: *** [all-recursive-am] Error 2
[root@mozart gnome-libs]#                                   

all my sources are from CVS, I've tried numerous things. ie,
reinstalled all my sources from scratch, make clean, reinstalled gtk
twice now..but i still get that compress/uncompress error regardless
of what i do....

glib, gtk+, imlib, and mico compile just fine.. butwithout those gnome
libs,, i cant proceed much farther :~(  

i'm on a redhat 5.0 system, using egcs , glibc etc.

Hope to hear from some happy ears soon , much appreciated any help you
can give.

Bob Soros

Get your free @yahoo.com address at http://mail.yahoo.com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]