Re: automake version used in gnome-common

On Wed, 2003-08-06 at 00:08, Jean Schurger wrote:
> Hi.
> 	The current gnome-common wants to use by default automake-1.4.

Well, sort of.

> 	Why not uses automake-1.7 ?

See below.

> 	Which gnome modules are not ready to uses it ?

Heaps of them. Try aliasing automake-1.4 to automake-1.6 and watch the
world blow up when you rebuild stuff (including running 'make distcheck'
on everything).

> 	And for theses, anybody know a doc to help to pass from automake-1.4 to
> automake-1.7 ?

See below.

The details....

The gnome-common module needs automake-1.4 to build and install itself
(in fact, I can probably make it portable; that will not be too hard).
However, that has nothing to do with which version of automake it uses
to build the GNOME packages.

By default, the macros2/ script, which a lot of modules end up
calling, will use automake-1.4 unless you tell it otherwise. A *lot* of
GNOME modules in the desktop and platform release still require

James Henstridge started to port a few modules over to automake-1.7
earlier this year, with some success (he also tidied some things up as
he went). I did a couple of others to also see what was involved.

Making that work go further is probably blocking on me at the moment,
since I started to write down all the steps involved so that people
could move their own modules, but it has languished for lack of time and
priorities lately. I have a fairly long document, so it's clearly not
just a couple of minutes to change things and tidy out all the cruft
(which if you are going to port forwards, you might as well do so that
future maintainers are not wondering why some archaic construct is still
in or For now, we are a long way from being
able to require automake >= 1.6, so it is not really a problem for any
individual module to stay requiring automake-1.4. It's also not a huge
burden on anybody to expect them to have automake-1.4 installed, since
it's parallel installable with other automake versions now (has been for
over a year).

I would not mind if we pushed to moving most modules to automake 1.6 or
later for the GNOME 2.6 timeframe (and probably we should just pick a
verison like 1.7 and standardise on that). We also need to pick an
autoconf and libtool version to standardise on so that everybody is
reading from the same page. It is not necessarily pragmatic just to use
the latest version of everything.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]