Re: [Render] question!

Vladimir Vukicevic <vladimir ximian com> writes: 
>  The
> difficulty lies in that patches are required to gtk+, gnome-libs, and
> gal; and also that a number of applications and utilities access the
> GdkFontPrivate structure directly and as such will crash if they are not
> modified.

See the gtk-devel-list thread for ideas on how to keep that from

> Luckily, the number of such applications is low -- the XFT
> support itself is enabled by a GDK_USE_XFT environment variable, so for
> those applications simply setting it to 0 fixes the problem. (It's
> surprising that even something like the desk guide applet crashes...)

Please call it XIMIAN_GDK_USE_XFT if it doesn't get submitted/merged
into GTK 1.2.9 proper. We would like to avoid answering questions
about a patch we haven't even seen. ;-)

Though, ideally it would get into 1.2.9 proper, again see the
gtk-devel-list thread for comments on that.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]