Re: Panel problems on Solaris

Elliot Lee wrote:
> On Thu, 18 Feb 1999, Maciej Stachowiak wrote:
> > I noticed that some of my libraries were built without debugging symbols
> > so I tried everything again, with ORBit-0.3.38, gnome-libs-,
> > gnome-core- and gtk+-1.1.15. I confirmed that tcp-wrappers is not
> > installed on my system. Here is a gdb backtrace of the coredump resulting
> > from trying to load the fish applet into the resulting panel (I cut off the
> > likely uninteresting Gtk+ dispatch code).
> >
> > #0  GNOME_Panel_add_applet (_obj=0x0, panel_applet=0x107280, goad_id=0xeed43a08 "fish_applet",
> >     cfgpath=0xefffcdf4, globcfgpath=0xefffcdf0, winid=0x153898, ev=0x0)
> >     at /u/racerx1/local/src/gnome-core-
> > #1  0xef78684c in gnome_panel_applet_corba_init (applet=0x1537f8, goad_id=0xeed43a08 "fish_applet")
> >     at /u/racerx1/local/src/gnome-core-
> The goad_server_activate_with_repo_id() call on line 652 must be failing.
> Can you try to find out why?

Right after I sent my message, I found a solution, although I am still not sure what
the problem was. On a lark I xkill'd the window identified as the GNOME_NAME_SERVER 
window. My panel works OK now. I'm not sure why I had a bogus name server running or
why this caused a problem that could not be fixed short of manual intervention, but
there are probably bigger fish to fry right now, bugwise.

 - Maciej

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]