Re: Solaris bug in libzvt/gnome-terminal

Maciej Stachowiak wrote:
> I've been investigating this bug. I ran both xterm and gnome-terminal
> under truss on Solaris with lots of options. I've figured out that
> the failed ioctl in the error message is an attempt by the spawned
> shell to do a TIOCGSID, i.e. an attempt to get the session ID of the tty.
> This fails with an ENOTTY. However, other termio icotls work fine on the
> same file descriptor. I don't know enough about terminal I/O and process
> groups to understand this failure. If anyone with more clue about these
> things would like to see the truss output, please email me, otherwise I
> will just sit and meditate with my Stevens book.

Nevermind, I fixed it (committing shortly). For anyone interested, the
problem is that the SVR4 version of the gnome-login-helper code was not
setting a controlling tty on SVR4 systems. The way I fixed it is kind of
a kludge, but a better solution would require a serious reworking of
the code.

Advice to future terminal code hackers: read chapters 9, 11 and 19 of 
"Advanced Programming in the UNIX Environment" really carefully before
you start coding.

 - Maciej

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]