Re: request change at GDA_Report.idl

> > > 
> > it's not a matter of correct/not correct, but of taste. That is, do we prefer
> > 
> > GDA_Report_Chunk, GDA_Report_Stream, etc, or GDA_Report_ReportChunk,
> > GDA_Report_ReportStream, etc?
> > 
> > I personally don't care too much now (maybe if some people raise their
> > hand about it, it should be changed), so, if you feel ok with the way
> > it's done right now, ok, don't change anything :-)
> > 
> You have not understand me, the part i was talking about is mapped as
> GDA_ReportStreamChunk, 

yes, you are right, I thought I had used:

module GDA {
    module Report {

but no, we use just "module GDA", so this is why all
interface/struct/type names are started with "Report".

but you are right, the other kind of names you
> have write before are more "beautiful" and I prefer them. Then, Can I
> modify the IDL to use those names?
if you really want, do it. The only change is to add the "module Report" line to

the IDL file, remove the suffix "Report" from all
interface/structs/types, etc, and change accordingly the source files:
Where there is GDA_ReportStream, it should look GDA_Report_Stream, etc,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]