Bonobo-related errors building out of CVS

I checked gnome-db out of CVS today, and tried to build it.  Before that,
I installed bonobo-0.9, which I got from:

I configured gnome-db with:

  ./ --with-mysql=/usr/local --with-postgres=/usr 

And when I run make, I eventually get this error:

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../gda-clnt -I../gda-clnt-ui
-I/usr/local/include -I/usr/include -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/lib/glib/include -I/usr/X11R6/include
-I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include
-I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/lib/glib/include
-I/usr/X11R6/include -g -O2 -Wp,-MD,.deps/gnome-db-control.pp -c  -fPIC
-DPIC gnome-db-control.c -o .libs/gnome-db-control.lo
gnome-db-control.c:52: parse error before `BonoboArg'
gnome-db-control.c:60: parse error before `*'
gnome-db-control.c: In function `control_factory':
gnome-db-control.c:90: `BonoboPropertyGetFn' undeclared (first use in this
gnome-db-control.c:90: (Each undeclared identifier is reported only once
gnome-db-control.c:90: for each function it appears in.)
gnome-db-control.c:90: parse error before `get_control_prop'
gnome-db-control.c: In function `gnome_db_control_class_init':
gnome-db-control.c:160: warning: assignment from incompatible pointer type
make[2]: *** [gnome-db-control.lo] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/bjepson/gnome/gnome-db'
make: *** [all-recursive-am] Error 2
Should I use a different release of bonobo?


Brian Jepson * (  *

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]