Re: [g-a-devel] Unable to run latest CVS snapshot of orca.

Sometimes if I have exited X abruptly and am having trouble logging back in to the desktop... I follow these steps:
1. log in as root to a safe shell
2. bonobo-slay
3. rm -rf /tmp/orbit*
4. exit

These seems to reset things.


Bill Haneman wrote:

Answer is "yes", because at-spi-registryd has an open connection to the X server and thus will exit if the Xserver dies.

You are right about bonobo-activation-server sometimes hanging around between logins. I think the latter is a bug.


Willie Walker wrote:

Hi Bill:

Is it the case that the AT-SPI registry will be guaranteed to quit
when you restart the X Server?  My hope has always been that the
answer is "yes," but I'm not sure this always is true -- I've run
into situations (I think) where bonobo activation and other
processes seem to just hang around and I need to either reboot or
go through a process of killing them one by one.


On Dec 7, 2005, at 11:25 AM, Bill Haneman wrote:

Janina's right of course, just restarting the X server (or logging out!) should have solved the problem.

It's probably a good idea to log out and back in after replacing a core component like the at-spi-registry anyway.

best regards,


Janina Sajka wrote:

Luke Yelavich writes:

On Thu, Dec 08, 2005 at 12:53:12AM EST, Willie Walker wrote:

Yikes - I've seen this before, and if I remember correctly,
it's because the AT-SPI Registry is corrupt.  Have you tried

Yes that helped, thanks.

For the record, wouldn't restarting X accomplish the same result? I'm
thinking Ctrl-Alt-Backspace?

I'd hate to see our environment degrade to the primitive resolutions
employed in that other OS ...

Luke Yelavich
GPG key: 0xD06320CE      (
Email & MSN: themuso themuso com
ICQ: 18444344

Gnome-accessibility-devel mailing list
Gnome-accessibility-devel gnome org

Gnome-accessibility-devel mailing list
Gnome-accessibility-devel gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]