Re: [g-a-devel]Re: proto at-spi patch ...



Hi Bill,

On Wed, 2002-01-09 at 12:42, Bill Haneman wrote:
> I would prefer that you keep the keygrab work separate as it is more
> dangerous and more likely to be rejected as a patch;

	I'm about to split that out - although I think that I've got the issues
under control now.

> Can you break this into smaller patches that preferably do not depend on
> one another?

	Yes - as I suggested.

> Hmm, well the short answer is that you can't get X to do that.  The only
> thing you can do is call XGrabKey, as the existing code does.  I am
> 99.9% sure that we cannot use gdk calls to implement the keygrab stuff
> we need, having looked at it at length before.

	This explains why I was seeing no key events.

> Pleeeeze don't even _think_ of changing the code in
> spi_controller_grab_keyboard, all we can safely change is the way in
> which spi_check_key_event is called.

	I believe the only change I made to spi_controller_grab_keyboard was
removing the O(n*n) list iteration on the GList, making it a plain
iteration instead.

> >         I'd also like to  rename SpiDeviceEventController to SpiController in
> > the C implementation it, would save a lot of typing and this header /
> > impl. is not installed.
> 
> I would prefer not to make that kind of API change now, we are in
> 'freeze' or at least we must argue for such changes to the release team.

	This is not an API chance since these files are not installed, and are
totally private to registryd, indeed why they are in the Spi namespace
at all is a good question.

> Someday I will have time to comment this I hope.  Certainly not at the
> moment, I'm afraid.  Suffice it to say that at the moment
> SPI_KEYLISTENER_ALL_WINDOWS is the only grab bit that should cause the
> XGrabKey stuff to be used.

	Oh - ok, I use that. Hmm,

	So I'll split the patch, fixup the X polling and re-submit. The const
on the events is the only important API change that we need to push out
- we can't afford to have people poking with the event structure we pass
them from cspi.

	Regards,

		Michael.

-- 
 mmeeks gnu org  <><, Pseudo Engineer, itinerant idiot




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]