move to GError



Hi,

I moved to GError instead of GConfError (following GLib 2.0
convention, GConfError is now the name of the error code enum).

GError has the same semantics as GConfError, but things are named
differently. You should be able to avoid using gconf_error_*
functions, in fact I may make those internal; try to use only
g_error_*.

Appended is a perl script that fixes most uses of GConfError.

GConf is a bit bloated at the moment with cut-and-paste of GError,
unicode char tables, and GMarkup; earlier I propsed a libgunicode for
GNOME 1.4, maybe it should be libglib-temporary or something and
contain all this stuff. Don't know.

Havoc

#!/usr/bin/perl -pi.bak

s/GConfError/GError/g;
s/gconf_error_copy/g_error_copy/g;
s/gconf_error_destroy/g_error_free/g;
s/gconf_clear_error/g_clear_error/g;
s/err->str/err->message/g;
s/error->str/error->message/g;
s/\(\*err\)->str/(*err)->message/g;
s/\(\*error\)->str/(*error)->message/g;
s/err->num/err->code/g;
s/error->num/error->code/g;
s/\(\*err\)->num/(*err)->code/g;
s/\(\*error\)->num/(*error)->code/g;





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]