Re: 2.13.90 fails on deskbar applet

I ran into this same problem on my Gentoo box.  The following steps
worked around the problem for me.  YMMV.

Step 1: Get the following patch from GNOME CVS to [1]:

RCS file: /cvs/gnome/deskbar-applet/,v
retrieving revision 1.70
retrieving revision 1.71
diff -u -r1.70 -r1.71
--- deskbar-applet-2.13.90/        2006/01/30 22:31:59     1.70
+++ deskbar-applet-2.13.90/         2006/01/31 22:06:40     1.71
@@ -55,8 +55,8 @@


 dnl * PyGTK & co for Gnome Streamer

Step 2: Replace the contents of files/pythonpath-fix.diff with the above

Step 3: Update the checksums by running "make makesum" in the
deskbar-applet directory

Step 4: Add the following three lines to the end of deskbar-applet/Makefile:
        (cd $(WORKSRC); autoconf)

Step 5: Set up the PYTHONPATH variable in your environment.  You'll need
to replace "/home/garnome" with whatever path you use for $main_prefix.
 Also make sure that the python version in the path matches what you
have installed. I did this in the same command I used to build (sorry if line gets wrapped):

Step 6: If all that works, run "make install"


Hope this helps you out.


Nikos Charonitakis wrote:
2006/2/3, Bob Kashani <bobk ocf berkeley edu>:
On Fri, 2006-02-03 at 10:33 +0200, Nikos Charonitakis wrote:
the message is: python module gnomeapplet not found.

i use fc4 and i have installed all gnome-python2 packages including gnome-python2-applet and gnome-python2-extras...

what is missing?
Weird, we fixed this...check to see that the patch to deskbar-applet (pythonpath-fix.diff) is being applied? Are you building from scratch or did you try and upgrade an existing install?
fresh install. i looked inside patch-pythonpath-fix.diff it contains nothing except a date!

Try running a 'make clean' in desktop/deskbar-applet.
i ve already done this

-- Bob Kashani

-- garnome-list mailing list garnome-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]