Re: Am I there yet? :-)

On Sat, 20 Mar 2004 14:27:50 -0800, Bob Kashani wrote:
>On Sat, 2004-03-20 at 13:04, Bob Gustafson wrote:
>> =============== build of garnome-2.5.92/desktop
>> Note - epiphany would not build without a build of Mozilla.
>> Have not gone back and adjusted the PKG_PATH variable.
>> To keep things moving, I just moved the epiphany out of the 'way'
>Did you install the mozilla devel packages?

I pulled mozilla from cvs - assume that I got the whole thing,
but maybe not. In my build tree, I don't have any files
that have a '.pc' extension (seems to be a requirement of epiphany)

My Mozilla 1.7b runs fine. It has the extra Debug and QA menu titles
to the right of the Help title.

>> 1) Need to get a new version of gstreamer into the tree.
>Latest version of gstreamer = gstreamer-0.8.0
>Version in garnome-2.5.92 = gstreamer-0.8.0

I ran into xml parse errors when gstreamer-0.8.0 was in my build
see below:

developing.xml:223: element qandaset: validity error : No declaration for
t qandaset
developing.xml:224: element sect1: validity error : No declaration for
element s
faq.xml:62: element article: validity error : No declaration for element
make[8]: *** [check-local] Error 4
make[8]: Leaving directory

Using fedora up2date steps over that problem (binary installs..)

>> 2) Need to talk to the Mozilla folks so that mozilla could be built
>> within garnome.
>It builds fine for me. What error are you getting?
>>     The untar of the moz.bz2 creates a directory called 'mozilla', which
>> is outside of
>>     the pattern expected by garnome 'mozilla-1.7b'
>They changed the name of the tarball. You need to add yet another
>-source to to the mozilla garball Makefile like this:
>DISTFILES = $(GARNAME)-source-$(GARVERSION)-source.tar.bz2

Great, I didn't know that feature was available.

>BTW: mozilla-1.7b won't run. It chokes when I try to run it.

I have been clicking and surfing using my mozilla-1.7b and I have
not run into any problems as yet. Using some of the tools in the
Debug menu gives interesting info, but no crashes as yet.

>> =============== build of XFree4.4.0
>> make World >& world.log &
>> tail -f world.log
>> ...
>> ...
>> make[5]: Leaving directory `/usr/local/cvs/xfree4.4.0/build/doc/man/GLU'
>> make[4]: Leaving directory `/usr/local/cvs/xfree4.4.0/build/doc/man'
>> make[3]: Leaving directory `/usr/local/cvs/xfree4.4.0/build/doc'
>> make[2]: Leaving directory `/usr/local/cvs/xfree4.4.0/build'
>> make[1]: Leaving directory `/usr/local/cvs/xfree4.4.0/build'
>> Sat Mar 20 11:48:49 CST 2004
>> Full build of XFree86 version (12 March 2004) complete.

Why not. 4.4.0 is a bigger number than 4.3.0
I was having some problems with my display and I hoped that
running with the latest version would cure my problems.

It seems as though a mouse works better if it is /dev/input/mice
on my system..

>> Note that
>> [user1 hoho2 desktop]$ cd /var/spool/up2date
>> [user1 hoho2 up2date]$ ls -l gstream*
>> -rw-------  1 root root  17125 Mar 17 09:56 gstreamer-0.8.0-1.i386.hdr
>> -rw-r--r--  1 root root 627840 Mar 17 10:00 gstreamer-0.8.0-1.i386.rpm
>Fedora Core 2 test1 fully updated already has the latest version of
>Gnome. Currently Gnome-2.6rc1.

That is good to know.

(But note the trailing -1 on the version number above..)

>Is there a reason why you want to install Gnome-2.6rc1 again with
>garnome-2.5.92 (Gnome-2.6rc1)?

I was having intermittent problems with the fedora up2date process.
It seems as though some of the mirrors have different loads at
(slightly) different times. I would get strange errors and when I
tried it again ('up2date -u'), it would run and update fine.
(It was using a different mirror)

Building with garnome was redundant, but that was my approach to
getting something that would work. Whichever way did the job first.

I had really good results with Garnome a month or so ago.

Also, I like the idea of having a completely separate build/run
tree to test with.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]