libgsf too old for gnumeric 1.1.10

I have garnome 0.17.  It builds fine and I can run it in a test environment.
I built it so that I could work on some stuff for the gnumeric people.  They
are currently working on 1.1.10.

However, garnome 0.17 builds 1.1.8.  I got 1.1.10, but it chokes on libgsf.
It wants a version >= 1.4.0, but garnome 0.17 has 1.3.0.

I tried moving to garnome 0.18, but I had many font issues when trying to
start it up.

I looked at the garnome 0.17 stuff and I think I can change the version of
libgsf it gets, but I couldn't find the sources on the GNOME website to get
the path right, and I would still need the checksum.

And I'm not all that confident that I can just plop a newer version of just
one of the libs in there and expect all to go along swimmingly...

Anyone have any opinions on the best way to proceed?:

Keep looking for the new libgsf and put it into garnome 0.17 because it *will*

Bite the bullet and just go to garnome 0.18 and work through the font issues.


In light of the terrorist attack on the U.S.:
	They that give up essential liberty to obtain a little temporary
	safety deserve neither liberty nor safety.
			-- Benjamin Franklin, 1759

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]