gnome-volume-manager 1.3.2



       Module: gnome-volume-manager
      Version: 1.3.2
  Uploaded by: Robert Love

http://ftp.gnome.org/pub/GNOME/sources/gnome-volume-manager/1.3/gnome-volume-manager-1.3.2.tar.gz
  md5sum: 85582b7bae862cffc72fa69098d5053c
    size: 364K

http://ftp.gnome.org/pub/GNOME/sources/gnome-volume-manager/1.3/gnome-volume-manager-1.3.2.tar.bz2
  md5sum: adce9ecd8d15e0bb647af56f3616ac47
    size: 296K

ChangeLog
---------

2005-06-30  Jeffrey Stedfast  <fejj novell com>

	* configure.in: Bumped version to 1.3.2

	* src/manager.c: #include dbus-glib-lowlevel.h to rid ourselves of
	that annoying warning about dbus_connection_setup_with_g_main()
	being undeclared.
	(gvm_device_is_writer): Rewrote as a loop to make this code more
	readable and more easily extended later - just ad an item to the
	list to check!

2005-06-29  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_run_cdplayer): Don't check autoplay_cda here,
	simply run the command if one is set.
	(gvm_cdrom_policy): Check autoplay_cda before calling
	gvm_run_cdplayer()
	(gvm_run_command): We can't get the device if it wasn't passed to
	us (not all are block devices).

	* src/properties.c (show_props): Set the icon for the printer.

2005-06-28  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_check_photos): Rewritten to check all
	case-variants of the dcim directory by scanning the mount point.

	Fixes to make it so that pluging in an iPod-Photo won't first
	prompt sync-music vs import-photos and then ask the user again if
	she'd like to import photos. Should also fix bug #155638.

	* src/manager.c (gvm_run_camera): Simplify. Don't prompt here,
	just run the command. Make our callers do the prompting.
	(gvm_autorun): Pass arguments in the proper order to
	gvm_check_dvd().
	(gvm_autorun): Do the photo-import prompting here.
	(gvm_run_ipod): Don't check autoipod here, leave that to our
	caller(s).
	(gvm_device_mounted): Check autophoto and autoipod here. Also, in
	the case of cameras, prompt for photo-import.

2005-06-27  Jeffrey Stedfast  <fejj novell com>

	Make sure that notification of changed-but-unwatched gconf keys
	don't confuse us into changing the state of the first watched
	gconf value.

	* src/properties.c (show_props): Make sure that no item in the
	hash table has a value of 0.
	(gconf_changed_cb): Updated for change.

	* src/manager.c (gvm_load_config): Make sure that no item in the
	hash table has a value of 0.
	(gvm_config_changed): Updated for change.

2005-06-27  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_run_cdplayer): Fixed the order of arguemnts
	to be the same as everything else (oops, missed this one before).
	(hal_device_added): Don't abort simply because a volume isn't
	mountable or the fsusage isn't "filesystem". We need to work for
	audio cds too. Fix this by keeping track of the media's
	mountability.
	(gvm_prompt): Can't call g_error_free() on NULL. Also make sure to
	keep the reference to the image widget, duh.
	(gvm_prompt): Move the label creation to *after* we add the
	secondary text, doh!

2005-06-27  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (hal_device_added): Check the fsusage, don't mount
	if it's not "filesystem". Avoids mounting the non-mountable volume
	on iPods.
	(gvm_udi_is_ipod): Check the storage_device for iPod info, not the
	mountable volume udi we are given.

2005-06-23  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_run_cdburner): Fixed order of arguments.

2005-06-22  Jeffrey Stedfast  <fejj novell com>

	* configure.in: Allow mount and unmount commands to be specified.

	* src/manager.c (gvm_run_command): Return the exit status of the
	command invoked.
	(gvm_device_mount): Now takes udi and mount_point arguments and
	calls gvm_run_command() to invoke the mount command.
	(gvm_device_unmount): Now takes udi and mount_point arguments and
	calls gvm_run_command() to invoke the unmount command.
	(gvm_ask_mixed): Fixed for gvm_device_mount() changes.
	(gvm_cdrom_policy): Same.
	(gvm_media_changed): Same.
	(hal_device_added): Same.
	(mount_all): Same.
	(unmount_all): Updated for changes to gvm_device_unmount().

2005-06-22  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c: Make all functions that take a udi, device, and
	mount_point argument use a consistant order: udi, device,
	mount_point.
	(main): Use g_signal_connect() rather than gtk_signal_connect()
	since the latetr is deprecated since gtk2.
	(gvm_run_command): Free the GError on error.
	(gvm_run_command): Changed the order of the arguments to be a
	little more logical (well, at least to me).
	(gvm_run_command): Rewrote the loop to not require a strdup of the
	command string and also fixed it such that the mount_point string
	gets properly shell quoted so that mount points with spaces will
	work as well as fixed to handle %% and properly handle other
	unknown %-cases to avoid getting into an infinite loop.
	(mount_all): Don't leak the fsusage property string.

2005-06-21  Jeffrey Stedfast  <fejj novell com>

	* gnome-volume-manager.schemas.in: Make Sonance the default app
	for ipods.

	* src/manager.c: Add gconf keys for "don't ask me again"
	checkboxes in the table of prompts.

2005-06-17  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_prompt): New function to prompt users (with
	the ability to save responses to prevent further pestering of the
	user if they choose "do not ask again").

2005-06-16  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_check_photos): Don't launch the camera app
	here, let our caller do that.
	(gvm_autorun): if gvm_check_photos() returns TRUE, launch the
	camera app.

2005-06-14  Jeffrey Stedfast  <fejj novell com>

	* configure.in: Instead of defaulting the mount/umount/nautilus
	paths to "no", default them to the command name (maybe it'll even
	work, whereas otherwise we run the command "no" which might never
	stop executing (think: `yes n`)). Also added a new configure
	option for ASSUME_SUBMOUNT.

	* gnome-volume-properties.glade: Added ipod settings.

	* gnome-volume-manager.schemas.in: Added ipod settings.

	* src/properties.c: Added the iPod config options to the table.
	(show_props): Load gnome-icon-ipod for the ipod icon.

	* src/manager.c: Conditionally disable the code that
	mounts/unmounts devices if ASSUME_SUBMOUNT is defined.
	(gvm_run_command): Instead of erroring when a parameter is
	unavailable, just replace it with an empty string so that at least
	it's possible that the program runs.
	(gvm_ask_autorun): Pass the path argument to the dialog string.
	(gvm_udi_is_camera): Function to detect cameras given a UDI
	(gvm_udi_is_ipod): Same but for iPods
	(gvm_run_camera): Handle prompting the user for both actual
	cameras and storage devices containing a dcim directory (no need
	to duplicate the code).
	(gvm_check_photos): Modified to call gvm_run_camera()
	(gvm_device_mounted): New function that does magic on mounted
	devices to see what they are and act accordingly. Split out from
	hal_property_modified().
	(hal_device_added): In the case that the device is not a
	mass-storage device, check if it is a camera (to support PTP
	cameras).
	(hal_property_modified): Call gvm_device_mounted().

2005-06-07  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (hal_property_modified): Use g_ascii_strcasecmp
	instead of g_strcasecmp as the latter is deprecated.

2005-06-18  Christian Rose  <menthos menthos com>

	* configure.in: Added "he" to ALL_LINGUAS.

2005-06-01  Jeffrey Stedfast  <fejj novell com>

	* gnome-volume-properties.glade: Renamed various widgets to match
	their gconf key names to make it easier to make the code
	table-driven on gconf keys.

	* src/properties.c: Changed to be table-driven like manager.c
	which more easily allows us to save single setting chanegs rather
	than re-saving all settings whenever any setting changes.

2005-05-26  Jeffrey Stedfast  <fejj novell com>

	* src/manager.c (gvm_config_changed): Instead of free()ing all the
	settings and then reloading everything from scratch, just update
	the changed setting.
	(gvm_load_config): Changed to allow more easier setting updates
	(everything is now table-driven)
	(to_be_or_not_to_be): Split out from gvm_load_config()

2005-04-11  Rajesh Ranjan  <rajeshkajha yahoo com>

	* configure.in: Added "hi" (Hindi) to ALL_LINGUAS.

2005-04-06  Roozbeh Pournader  <roozbeh farsiweb info>

	* configure.in: Added "fa" (Persian) to ALL_LINGUAS.

2005-03-31  Steve Murphy  <murf e-tools com>

        * configure.in: Added "rw" to ALL_LINGUAS.

2005-03-31  Robert Love  <rml novell com>

	* src/manager.c: more grammar crap.

-- 
An RSS 2.0 feed of ftp-release-list is available at:
http://ftp.gnome.org/pub/GNOME/LATEST.xml



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]