Re: libgphoto2 installing problems with f-spot 0.0.12

michael szul said:
> I'm trying to upgrade from f-spot 0.0.6 to 0.0.12, but I'm having some
> trouble with the libgphoto2 requirement. I get the following when I try
> to do configure:
> configure: error: Library requirements (libgphoto2 >= 2.1.4) not met;
> consider adjusting the PKG_CONFIG_PATH environment variable if your
> libraries are in a nonstandard prefix so pkg-config can find them.
> I then downloaded libgphoto2-2.1.4 and gphoto2-2.1.4 (in tarball
> format); ran the usual configure, make, make install; and then changed
> my $PKG_CONFIG_PATH to make sure that pkgconfig was there.
> $PKG_CONFIG_PATH now looks like:
> :/usr/bin:/usr/lib/gaim:/usr/lib:/usr/local/lib:
> /usr/lib/pkgconfig:/usr/local/lib/pkgconfig
> If I run gphoto2 --version I get:
> This version of gphoto2 is using the following software versions and
> options:
> gphoto2           2.1.4        gcc, popt, exif, no cdk, no aa, jpeg,
> readline
> libgphoto2        2.1.4        i386-redhat-linux-gcc, EXIF, no ltdl,
> /proc/meminfo
> libgphoto2_port   0.5.1        i386-redhat-linux-gcc, USB, serial
> baudboy locking, no ltdl
> But when I go back to configure f-spot 0.0.12 again, I still get the
> above mentioned error about libgphoto2. Am I missing something?

Can you find an actual libgphoto2.pc file inside $PKG_CONFIG_PATH ? 
That's what it wants.  Easy way is to "sudo updatedb; locate \*.pc" or

michael at msdavies dot net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]