Re: [evolution-patches] Re: [Evolution-hackers] gtk_message_dialog() alternatives
- From: Not Zed <notzed ximian com>
- To: jdieter99 gmx net
- Cc: evolution-patches lists ximian com
- Subject: Re: [evolution-patches] Re: [Evolution-hackers] gtk_message_dialog() alternatives
- Date: Thu, 17 Mar 2005 12:02:50 +0800
Hi,
Instead of doing below, you should probably use em_utils_prompt_user(). It presents this type of question in a standard way (i guess i didn't look closley enough to see if that had been set). I think you can use it - it has a funny api so it might not be usable in this specific case. If not, then please copy its implementation - i.e. by using identical strings and layout.
default-client-mail-check is a bit of a mouthful, how about "default-mailer"?
There are some stylistic things that you should try to follow closer to the rest of the code - but to be honest i couldn't care less for a plugin. e.g. dialogDefaultEmailApp - why not just call it "dialog".
I guess it is just about there though.
It would be better to use the newer method of i18n for error files too - but i wont decline the patch based on that. It isn't in the documentation properly, it is only in the eplugin skeleton i posted to the evolution blog several months ago.
Thanks,
Michael
On Wed, 2005-03-16 at 16:01 +0200, Jonathan Dieter wrote:
dialogDefaultEmailApp = e_error_new(NULL, "org.gnome.default-mail-client-check:ask-default-mail", NULL);
+
+ checkAlways = gtk_check_button_new_with_label("Always ask this question");
+ gtk_toggle_button_set_active(GTK_TOGGLE_BUTTON(checkAlways), TRUE);
+
+ gtk_container_add(GTK_CONTAINER(GTK_DIALOG(dialogDefaultEmailApp)->vbox), checkAlways);
+
+
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]