Re: [evolution-patches] Exchange: patch for bug #221030
- From: Sarfraaz Ahmed <asarfraaz novell com>
- To: Shakti Prasad <shprasad novell com>
- Cc: Patches List <evolution-patches lists ximian com>
- Subject: Re: [evolution-patches] Exchange: patch for bug #221030
- Date: Sat, 13 Aug 2005 16:38:46 +0530
Hi,
[ I didnt get a mail for this patch from the patches list, so trying to
recreate a reply with the patch attached from bugzilla. ]
This looks good. Just a few minor changes needed.
-- Sarfraaz
> Index: addressbook/e-book-backend-exchange.c
> ===================================================================
>
>
> -#ifdef ENABLE_CATEGORIES
> static void
> proppatch_categories (PropMapping *prop_mapping,
> EContact *new_contact, EContact *cur_contact,
> E2kProperties *props)
> {
> - gboolean changed;
> - char *new_categories, *cur_categories = NULL;
> - EList *categories;
> - EIterator *iter;
> + GList *new_categories_list = NULL;
How about just naming this as categories_list only.
> + GList *l = NULL;
> GPtrArray *array = NULL;
And this array as prop_array ? Makes it more clear where these structures are being used for.
> - new_categories = e_contact_get (new_contact, field);
> - if (cur_contact)
> -populate_categories(EContactField field, EContact *new_contact, void *data)
> +populate_categories (EContactField field, EContact *new_contact, void *data)
> {
> - GSList *list = data;
> - GSList *l;
> - EList *categories;
> -
> - categories = e_list_new ((EListCopyFunc) g_strdup,
> - (EListFreeFunc) g_free,
> - NULL);
> + GList *list = NULL;
> + GPtrArray *lst = data;
Similarly give some better names for these 2 structures.
> + gint i;
-- Sarfraaz
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]