Re: [evolution-patches] [Fwd: [Evolution-hackers] Make attachment properties instant apply + HIGgy]



On Wed, 2004-06-02 at 09:32, Christian Neumair wrote:
> -------- Weitergeleitete Nachricht --------
> > Von: Christian Neumair <chris gnome-de org>
> > An: evolution-hackers lists ximian com
> > Betreff: [Evolution-hackers] Make attachment properties instant apply
> > + HIGgy
> > Datum: Wed, 02 Jun 2004 14:31:57 +0200
> > The attached patch makes the attachment property dialog instant apply
> > and is a first shot at making it HIG compliant. The MIME entry has been
> > replaced by a label because it isn't editable at the moment and most
> > probably we won't get a nice MIME type picker for the next few months.
> 
> Sorry, wrong list.
> 
> ______________________________________________________________________
> Index: composer/e-msg-composer-attachment.c
> ===================================================================
> RCS file: /cvs/gnome/evolution/composer/e-msg-composer-attachment.c,v
> retrieving revision 1.52
> diff -u -r1.52 e-msg-composer-attachment.c
> --- composer/e-msg-composer-attachment.c	31 Mar 2004 10:08:03 -0000	1.52
> +++ composer/e-msg-composer-attachment.c	2 Jun 2004 12:30:03 -0000
> @@ -33,6 +33,7 @@
>  #include <errno.h>
>  
>  #include <camel/camel.h>
> +#include <gtk/gtklabel.h>
>  #include <gtk/gtknotebook.h>
>  #include <gtk/gtktogglebutton.h>
>  #include <gtk/gtkdialog.h>
> @@ -284,8 +285,8 @@
>  	GtkWidget *dialog;
>  	GtkEntry *file_name_entry;
>  	GtkEntry *description_entry;
> -	GtkEntry *mime_type_entry;
> -	GtkToggleButton *disposition_checkbox;
> +	GtkLabel *mime_type_label;
> +	GtkToggleButton *disposition_toggle_button;
>  	EMsgComposerAttachment *attachment;

ugh. don't the change the name of the disposition_checkbox for no
reason.

and PLEASE keep mime_type_entry as a GtkEntry.

>  } DialogData;
>  
> @@ -302,15 +303,14 @@
>   */
>  
>  static void
> -set_entry (GladeXML *xml, const char *widget_name, const char *value)
> +set_widget_value (GtkWidget *widget, const char *value)
>  {
> -	GtkEntry *entry;
> -	
> -	entry = GTK_ENTRY (glade_xml_get_widget (xml, widget_name));
> -	if (entry == NULL)
> -		g_warning ("Entry for `%s' not found.", widget_name);
> -	else
> -		gtk_entry_set_text (entry, value ? value : "");
> +	g_return_if_fail (widget != NULL);
> +
> +	if (GTK_IS_ENTRY (widget))
> +		gtk_entry_set_text (GTK_ENTRY (widget), value ? value : "");
> +	else if (GTK_IS_LABEL (widget))
> +		gtk_label_set_text (GTK_LABEL (widget), value ? value : "");

this change won't be needed anymore since mime_type_entry must stay an
entry widget.

anyways, a lot of other stuff doesn't need to change either.

[snip]

> Index: composer/e-msg-composer-select-file.c
> ===================================================================
> RCS file: /cvs/gnome/evolution/composer/e-msg-composer-select-file.c,v
> retrieving revision 1.27
> diff -u -r1.27 e-msg-composer-select-file.c
> --- composer/e-msg-composer-select-file.c	19 Apr 2004 15:20:26 -0000	1.27
> +++ composer/e-msg-composer-select-file.c	2 Jun 2004 12:30:03 -0000
> @@ -71,7 +71,7 @@
>  	}
>  
>  	if (showinline_p) {
> -		showinline = gtk_check_button_new_with_label (_("Suggest automatic display of attachment"));
> +		showinline = gtk_check_button_new_with_mnemonic (_("Suggest _automatic display of attachment"));
>  		gtk_widget_show (showinline);
>  		gtk_box_pack_end (GTK_BOX (selection->main_vbox), showinline, FALSE, FALSE, 4);
>  	}

this part is fine I guess.

Jeff




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]