[evolution-patches] fix for bug #41514 (ui)



http://bugzilla.ximian.com/show_bug.cgi?id=41514

Another suggested change might be to change the name of close_button to
cancel_button (since it's not a close button really). Also would require
some updating of the src tho. Also change the name of the callback from
close_cb() to cancel_cb()?

I skipped the src changes since they aren't really necessary, they would
just (imho) make the code nicer to read.

however, unnecessary so I unless NotZed is okay with those changes as
well, I won't bother wasting time on it.

Jeff

-- 
Jeffrey Stedfast
Evolution Hacker - Ximian, Inc.
fejj ximian com  - www.ximian.com
? 41514.patch
Index: e-msg-composer-attachment.glade
===================================================================
RCS file: /cvs/gnome/evolution/composer/e-msg-composer-attachment.glade,v
retrieving revision 1.9
diff -u -r1.9 e-msg-composer-attachment.glade
--- e-msg-composer-attachment.glade	11 Apr 2003 20:48:47 -0000	1.9
+++ e-msg-composer-attachment.glade	18 Apr 2003 18:18:42 -0000
@@ -26,27 +26,27 @@
 	  <property name="layout_style">GTK_BUTTONBOX_END</property>
 
 	  <child>
-	    <widget class="GtkButton" id="ok_button">
+	    <widget class="GtkButton" id="close_button">
 	      <property name="visible">True</property>
 	      <property name="can_default">True</property>
 	      <property name="has_default">True</property>
 	      <property name="can_focus">True</property>
-	      <property name="label">gtk-ok</property>
+	      <property name="label">gtk-cancel</property>
 	      <property name="use_stock">True</property>
 	      <property name="relief">GTK_RELIEF_NORMAL</property>
-	      <property name="response_id">0</property>
+	      <property name="response_id">-6</property>
 	    </widget>
 	  </child>
 
 	  <child>
-	    <widget class="GtkButton" id="close_button">
+	    <widget class="GtkButton" id="ok_button">
 	      <property name="visible">True</property>
 	      <property name="can_default">True</property>
 	      <property name="can_focus">True</property>
-	      <property name="label">gtk-cancel</property>
+	      <property name="label">gtk-ok</property>
 	      <property name="use_stock">True</property>
 	      <property name="relief">GTK_RELIEF_NORMAL</property>
-	      <property name="response_id">0</property>
+	      <property name="response_id">-5</property>
 	    </widget>
 	  </child>
 	</widget>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]