[Evolution-hackers] Found key binding bug, need hint!

I found a bug in key bindings for evo but I don't know
how to fix it, and I need som hint on how things are glued together.

I also tried to report on bugzilla, but found that the bug was already
reported in Nov (http://bugzilla.gnome.org/show_bug.cgi?id=269404)
and there were other related reports like 150059, 259331 and 232441,
still not fixed, which urges the need to do someth.

The bug is that emacs key bindings (after my last upgrade) only works
in about 50% of the cases for the first composed email after each new
invokation of evolution. In the following they are not working at all.
This must be a problem in evolution, probably in message-tag-followup.c
but I'm not experienced enough with gtk to tell. This simply means I
can't use evolution any more if I'm not able to fix this.

The fundamental bug is obviously an evo one, but the related problem
may be a general gtk one. For now there are only two options in gtk,
either use the default weird windoze inspired keys or emacs style, but
what about other preferences like vi? This interface needs to be made
more general.

For every programmer keybindings are essential, I'm an emacs user and
have used different flavours of emacs (Amis, Multics emacs, Gosling emacs,
Gnu emacs) during my 25 years of hacking.
I'm using emacs keys with openoffice, that works fine. I even used emacs
keybindings in MSWord, when I used that for a while around 1990 on a
Mac at the university.

In the Gnome environment emacs key bindings usually work fine,
like now in Firefox when I'm writing this with gmail, although in some
applications, like thunderbird, the application "steals" keys which can
cause very annoying behaviours, this needs to be fixed as well.
Obviously evolution does some weird things with the keys as the
keys don't work at all in the composer header. Apart from when
I get a meny, like when having several destinations to choose from,
then the emacs key bindings are suddenly working again in the

Apart from the evolution problem I assume that gtk keybindings may
need some fresh up. The way e.g. thunderbird does is unforgivable
and reminds me about the old MSDOS... When I pressed ^P there
I was asked about printer. The same as in the old DOS if you accidentaly
hadn't loaded the dosedit environment with proper emacs keys.

For applications that include key settings options (like openoffice and
evolution in release 1.0) it seems not to be a problem, but in applications
that rely on a proper gtk key behaviour problems arise, if the applications
them self lock some keys in.

Anyway, the urgent thing is to fix keys in evolution. If someone has
a hint I'm grateful.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]