[Evolution-hackers] more camel api changes again, CamelFolderInfo

I had to change some other related stuff so i bit the bullet and did
some outstanding wants on CamelFolderInfo:

 - s/sibling/next/, and moved it to the head of the structure, to make
it consistent with other (albeit later-written :) tree node structs in
 - s/unread_message_count/unread/ 'cause i got sick of the typing
 - s/url/uri/ more consistent with the mailer now
 - added a 'total' count, semantics the same as unread

Also added a CAMEL_FOLDER_SYSTEM bit, indicates the folder cannot be
renamed/deleted.  i.e. to support ui elements.

Changed the semantics of CAMEL_FOLDER_VIRTUAL.  Just means its a virtual
folder, i.e. cannot move messages to it.  Doesn't mean you can't create
subdirs on it (use NOINFERIORS for that).

And added CAMEL_FOLDER_VTRASH, means you can move to it, but can't copy
to it, and can't filter to it.

This is so the ui can more better define what you can and can't do,
without all the special case/strcmp/other checks.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]