Re: plan to drop automake-1.6 from jhbuild

James Henstridge <james jamesh id au> writes:

> Currently jhbuild builds a large number of versions of automake during
> bootstrap (currently 1.4-p6, 1.6.3, 1.7.9, 1.8.5 and 1.9.1), which is
> only going to grow in the future.
> Out of the ones jhbuild currently distributes, the ones I think
> definitely need to be there include:
>     * automake-1.4: some packages are still using ancient Automake
>       (although it would be nice to upgrade the last few of these packages).
>     * automake-1.7: GTK 2.4 depends on this particular version.
>     * automake-1.9: it should be easy for a package to use the latest
>       automake (or just test against it), so we don't end up in the
>       situation we were in a few years back where we are stuck with an
>       old unsupported automake version.
> I'd like to drop 1.6.3 from the jhbuild bootstrap list, since it is
> mostly compatible with 1.7 and it contains known bugs that have been
> fixed in later releases.  At some point, it might be worth removing 1.8
> too.
> What does everyone else think about this?

It sounds like a good plan.  Do packages still require automake-1.4,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]