Re: about autoconf, automake and gettext versions

On Mon, 2003-12-29 at 20:45, Ali Akcaagac wrote:
> > For example, if one GNOME Desktop modules needs automake1.7 it
> > has no sense to maintain other modules asking for automake1.4
> Would be nice using automake 1.8 now that it is out for a couple of
> weeks. But mainly I think we all agree here that going with one version
> makes sense.

There is the problem: it has only been out for a couple of weeks. It is
far too early to completely rely on it. When it's been out for a couple
of months, then we might be able to feel comfortable. We also should not
willingly go down a path that requires everybody to upgrade a package
like this. Something that was released on December 10 is in precisely
zero released distributions (Debian "unstable" is not a released
distribution) at the moment and we just don't know what problems there
might be. Witness the fun involved with some candidate SuSe and Debian
libtool packages over the past few months -- these things can go wonky
in very subtle ways.

That is not to say that I think people should be discouraged from using
recent versions, but rather that we should not use features that are
only available in 1.8. For now, the pragmatic route is to make things
that build with 1.7, since then 1.7 or 1.8 could be used. It isn't worth
bumping the requirement too far for no good reason.

Looking over the final NEWS file for the 1.8 release, there does not
appear to be anything there we really, really need that cannot already
be achieved by other means. In fact, there may be some excitement in
some packages because of the changed definition of $(top_distdir) --
this will be transparent to almost everything and I cannot immediately
think of a way it will break something, but it is a non-trivial change
that needs testing.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]