Re: Beagle problems on FC3

Here is what I have found so far, with the beagle installation on my kernel-2.6.11-1.14_FC3. It is a nice package, with a lot of promise! BTW I am using it in a Gnome desktop...

I have solved the problem of "best" crashing, by making changes to "/usr/bin/best" in the references to "usr/lib/mozilla-1.7.8" to "/usr/lib/mozilla-1.7.10" (or whatever is appropriate for your computer) as shown below:


But now have run into another! I am able to make "best" work & show search results, but when I click on some search entries no windows open up to display the file & I get:

Open URI: action:_tile_9!Open
Cmd: htmlview
Arg:  'file:///home/.../File1.html'
Error in OpenFromMime: System.ComponentModel.Win32Exception: Cannot find the specified file in [0x00289] (at /usr/src/redhat/BUILD/mono-1.1.7/mcs/class/System/System.Diagnostics/Process.cs:823) System.Diagnostics.Process:Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) in [0x00007] (at /usr/src/redhat/BUILD/mono-1.1.7/mcs/class/System/System.Diagnostics/Process.cs:856) System.Diagnostics.Process:Start ()
in (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()
in <0x0023a> Beagle.Tile.Tile:OpenFromMime (Beagle.Hit hit, System.String command_fallback, System.String args_fallback, Boolean expects_uris_fallback)

Seems to happen with files like (.html; .pdf; .gif) and maybe other file types that I have not tested.

The GOOD news is, some files (like .xls; .doc) seem to open by OpenOffice being invoked:

Open URI: action:_tile_482!Open
Cmd: oowriter
Arg:  'file:///home/.../File2.doc'
Done Rendering: 6.32s

Any clue as to what I can do to fix this partial problem with .html & .pdf files without having to compile "beagle" from sources, because I tried that and quickly ran into dependency hell!

Thanks all

jmb365 wrote:

I have installed beagle via apt on FC3 kernel-2.6.11-1.14_FC3.
I have the following successes:
1. beagle is successfully installed via apt-get including the necessary dependencies.
2. beagled is running (after resolving some glitches)
3. beagle-settings (Not found! )
4. beagle-config (Only a limited command set is available)
5. beagle-query (Works)
6. beagle-status (Works)
7. beagle-info --index-info (Shows several 100's files indexed, uncrawled & dirty)

& failures:
8. best does NOT run (See errors below)
9. http://localhost:8888/ results in "Connection refused ..." message even if my firewall is disabled.

1. How do I resolve issue 8?
2. Do I need to wait till all files have been crawled (zero dirty files) before http://localhost:8888/ will have a webserver running? Is the webserver enabled when the rpm was created or do I need to compile (Yuck!) from CVS to get an enabled version?


My install steps were:

wget -nd
rpm -Uvh
wget -nd --passive-ftp
rpm -ihv libsqlite-2.8.12-2.athlon.rpm

perl -pi -e 's/# rpm /rpm /' /etc/apt/sources.list.d/nrpms-mono.list
apt-get update
apt-get install beagle

beagle-settings            # Not found!

beagled --fg --debug
# INFO: Starting Beagle Daemon (version
# DEBUG: Command Line: /usr/lib/beagle/BeagleDaemon.exe --fg --debug
# FATAL: Could not set extended attributes on a file in your home directory. # See for more information.

# So I set extended attributes, in /etc/fstab file
# "/dev/VolGroup00/LogVol00 /   ext3    defaults,user_xattr     1 1"
# And Remount the affected partitions as follows:
mount -o remount /

export MONO_LOG_LEVEL="debug"
export MONO_LOG_MASK="dll"

beagled                (Runs ! )

# Logs show that sqlite is not found. The fix is:
ln -s /usr/lib/ /usr/lib/

# The webserver is not running and
# Still unable to connect to http://localhost:8888/
# Mono-INFO: DllImport error loading library: ' cannot open shared object file: No such file or directory'. # Have "/usr/lib/" but NOT ""; (I need to install this!)

best                # Bleeding Edge Search Tool
# Unhandled Exception: System.DllNotFoundException:
# in (wrapper managed-to-native) Beagle.Util.GeckoUtils:blam_gecko_utils_init_services ()
# in <0x00007> Beagle.Util.GeckoUtils:Init ()
# in <0x00082> Best.Best:Main (System.String[] args)
# /usr/lib/beagle/    # Does exist !
# ln -s /usr/lib/beagle/ /usr/lib/ # Does NOT fix the problem!

beagle-query hello        # Works! Finds "hello" in various files
beagle-status # Works and shows indexing is progressing...
beagle-info --index-info   # Works

Any & all help would be vvery much appreciated!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]