Re: [PATCH] Introduce vnc_util_get_version() functions to get version
- From: Michal Novotny <minovotn redhat com>
- To: Jonh Wendell <jwendell gnome org>
- Cc: gtk-vnc-list gnome org
- Subject: Re: [PATCH] Introduce vnc_util_get_version() functions to get version
- Date: Thu, 30 Sep 2010 15:38:06 +0200
On 09/30/2010 03:14 PM, Jonh Wendell wrote:
Em Qui, 2010-09-30 às 14:58 +0200, Michal Novotny escreveu:
On 09/30/2010 02:45 PM, Jonh Wendell wrote:
About the patch, three notes:
1) str must be freed with g_strfreev
2) retVal should be renamed to ret_val or just ret?
3) about vnc_util_get_version_string(), couldn't it return a const gchar
* (return VERSION;)?
Cheers,
Ok, thanks for your valuable input since I'm not familiar with the GNOME
String functions very much so that's why I did something that could be
done better. Nevertheless I'll have a look after I finish at work today.
Why should I rename retVal to ret_val or ret ? I'm just curious why.
Also, the point 3 - do you mean implement as "return (const char
*)VERSION" ?
item 2), just for convention. I don't see in gtk-vnc any variable
withThisStyle.
item 3)
const gchar * get_version_string ()
{
return VERSION;
}
Cheers,
Ok, thanks. I've been recompiling the kernel now so I did patch it.
Also, I implemented the vnc_util_check_version() function with prototype
of "gboolean vnc_util_check_version(gint major, gint minor, gint
micro)". The new version has been sent to the list with "[PATCH v2]
Introduce vnc_util_get_version() functions to get version" subject.
Michal
--
Michal Novotny<minovotn redhat com>, RHCE
Virtualization Team (xen userspace), Red Hat
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]